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formatting options are
automatically adjusted to match
printer settings.

Introduction

Versions 6.08 and 6.10 of the SAS
System under both OS/2 and Windows
introduced several new features
which facilitated the printing
process. One especially useful,
but complex feature, introduced in
SAS 6.08 was the ability tq print
through a form. The forms subsystem allows one to create
customized templates containing
printer attributes. Version 6.10
contains additional printing
options so that the forms subsystem is no longer necessary.

To Use or Not to Use Forms

While the forms sub-system is no
longer necessary, forms remain a
useful printing alternative,
especially when using more than
one print configuration. The main
drawbacks of the forms sub-system
are the amount of time the initial
setup requires, a new form is
needed for each print
configuration, and a knowledge of
printer control language is
necessary. While these are valid
criticisms of the forms subsystem, they are offset by the
following:

This paper presents a tutorial for
printing under OS/2 and Windows.
The tutorial will cover printing
alternatives in SAS 6.10, print
setup, printing without the forms
sub-system, printing through
forms, and creating forms. The
paper will also note the
enhancements that accompany
Version 6.10 of the SAS System.

1) Normally a user/organization
needs only about four
different. print configurations.
.Landscape compressed and
uncompressed and portrait
compressed and uncompressed.

Printing in SAS 6.10

2) Only one person in an
organization must be
knowledgeable in the forms
creation process and in printer
control language. Once forms
are set up, the forms can be
copied into a user's
SASUSER.PROFILE.

In SAS 6.10, as well as 6.08, the
contents of each window is a
simple stream of text which does
not include printer control codes
for print attributes such as page
breaks, page orientation, margins,
or font characteristics. In SAS
6.08 in order to get the desired
print configuration a form was
used. A form is simply a template
which describes printer
attributes.

3) Once forms are set up, it is
quicker to change print
configurations by specifying
a new form than by going
through a series of dialog
boxes.

In SAS 6.10 the forms sub-system
still exists, but is being
deemphasized. Forms are no longer
necessary to control printer
attributes such as margins, fonts,
or page orientation. Instead,
output can be customized by using
a series of print dialog boxes. A
second enhancement in SAS 6.10 is
that the linesize and pagesize

4) If forms were setup in SAS 6.08
they still work in SAS 6.10.
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Printing from the SAS Application
Work Space (AWS)

current print form. If the
current print form contains
printer control characters,
then the system's printer
object must be by-passed. In
SAS 6.10, this is accomplished
by specifying the SAS system
option Sysprint with only the
first argument, as in the
following statement:

The SAS AWS has three menu items
related to printing, all under the
File menu:

* Print
* Print setup
* Print utilities
The Print setup is necessary if
print configurations other than
the default are needed. By
default, the system default
printer along with its print
configuration is used. Therefore
the first consideration when
printing is print setup
configuration.

options sysprint='lpt1:'
If Use Forms is selected then
all other fields will not be
available to you.
NOTE: If you are printing through
a form, the desired form must be
selected before invoking the Print
Dialog box. To specify a form as
the current form type FORMNAME
form name on the command line,
where form name is the desired
form. Once-a form is selected, it
becomes the default form for the
duration of the current SAS

Print Setup

You can access the Print setup
dialog box (Figure 1) by selecting
'File' -> 'Print Setup' from the
SAS AWS or by choosing the setup
button from the Print dialog box.

session~

Below is summary of the
information presented in the Print
Setup dialog window.
Printer:
Displays the currently selected
printer and its port location.
SAS looks for the default
printer in the following places
in order of precedence: 1) the
SYSPRINT system option; 2) the
settings in the
SASUSER.PROFILE.OS2PRINT(for
OS/2) or
SASUSER.PROFILE.WNPRINT(for
Windows) catalog member; and 3)
the system default printer. A
Printer other than the default
can be selected by clicking on
the arrow portion of the field
and then choosing another
printer from the listbox.
The
default printer can also be
changed by using the SYSPRINT
system option.

Figure 1. Printer Setup Dialog Box

Font:
The Font field displays the
current font. To change the font
choose the Fonts button (see
belOW).
Line Size and Page Size:
Displays the calculated line
size and page size for the
current printer and font
settings. You cannot directly
reset the values in this box.
They are adjusted by Changing
the font, font size, margins,
or page orientation.

Use Forms:
To print through the forms subsystem, select the Use Forms
checkbox. The SAS system will
print your output using the

More:
By clicking on the More button,
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a printer specific dialog box
will be displayed. The contents
of this dialog is based on the
printer selected. Printer
attributes that can be set in
this dialog box include

Below is a summary of the options
in the Print dialog box.
Printer:
Displays the currently selected
printer and port (as shown in
Figure 2). If you are bypassing print manager, only the
port will be displayed. Click
on the setup button to select
another printer or to change
the print settings. This will
display the Printer Setup
Dialog box described above.

orientation, number of copies,

resolution, dual-sided printing,
and performance options.
Page:
The Page button can be selected
to set top, bottom, left, and
right margins.

Contents of:
Displays the name of the window
that you want to print. You can
click on the arrow part of the
field to choose between the
currently selected window and
the clipboard.

Fonts:
You can click on Fonts to
display a list of available
fonts. You can choose a font,
font style(i.e. bold), font
emphasis, and font size.
Once you have completed setting
the printer options, click on OK
to save your configuration and
close the Printer Setup dialog
box.

Print to File:
You can route your printed
output to a file, by selecting
the Print to File checkbox and
specifying a filename. By
saving the contents of a window
in the Print dialog box, you
can ensure that the file will
contain all the desired printer
control information. When the
contents of a window is saved
using 'File' -> 'Save as', the
file will not be formatted with
regard to page size or page
ejects.

The Printing Process

Once printer setup is complete,
the printing process is similar
for both of the printing methods
described above.
From the DMS window that you
would like to print, use the
popup menu to select 'File' ->
'Print'. This will bring up the
Print dialog box(Figure 2).
This box can also be displayed
by making the desired DMS window
active and selecting the AWS menu
items 'File' -> 'Print' or by
clicking on the printer icon.

Print as Bitmap:
You can print your output as a
bitmap instead of text, by
selecting the Print as Bitmap
checkbox.
Hold Print Requests:
Add the print request to a
queue. You can hold several
print requests and release them
all at once by selecting 'File'
-> 'Print Utilities' -> 'Release
print queue'.
Force Bitmap to Fill Page:
Scales the bitmap as needed to
fill the entire page. The Print
dialog window only displays this
checkbox when you select Print
as Bitmap.

Figure 2. Print Dialog Box
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Once you have completed setting
the print options click on OK to
print the file and close the Print
dialog box.

In the Form window, specifying a
libname or catalog name is
optional. By Default, the form is
stored in SASUSER.PROFILE. If you
choose to specify a catalog name
that is associated with a
permanent library, the form will
be saved in that library. In the
form name field, enter the name of
a form to be edited or the name of
a new form to create. You can
click on the DEFAULT button to
make this form the default form.
Click on the OK button to begin
editing the form.

Notes on Printing Through Print
Manager
1. If you print through a form
that contains printer control
characters you must by-pass
print manager. Print manager
will interpret them as text to
be printed.
2. When using this method, SAS
output can be managed as any
other output under OS/2 or
Windows. You can hold jobs,
delete queued jobs, change the
priority or jobs, and monitor
the queue.

Printer Selection Frame -- When
creating a new form, the Printer
Selection frame is the first frame
to appear. This window only
appears when creating a new form.
Move your cursor to the printer
that best matches the one you are
using and press ENTER. Your
selection will take effect and the
Text Body and Margin Information
frame is displayed (Figure 3). It
should be noted that once you have
made your printer selection, you
cannot return to this frame.

3. A print job can be held by
selecting Hold Print Requests
from the Print dialog box as.
described above. A job can also
be held by changing the status
to 'Hold' on the OS/2 or
Windows printer object. This
causes all jobs to be held
until the status on the printer
object is changed to 'Release'.
Creating Forms in OS/2 or Windows
Customized Forms can be created
using the FORM window. The FORM
window consists of six screens
that allow you to create a catalog
entry for a specified printer and
host system. Information on
linesize, pagesize, orientation,
font type and size, printer
margins, and printer control
language can be specified.

Figure 3. Text Body and Margin
Information Frame
Text Body and Margin Information-When editing an existing form, the
Text Body and Margin Information
frame is the first frame to
appear. In this frame you
can specify page formats by
editing the following fields.
You can obtain information on the
acceptable values for any of the
fields in this frame by typing '?'
in the field and pressing enter.

You can create or edit a form by
selecting 'File' -> 'Print
Utilities' -> 'Open a Form' from
the popup menu of any window. This
will invoke the Open a Form
window. You can also create or
edit a form by typing FSFORM
formname on the command line of
any window (where formname is the
name of the form that you would
like to create or edit).
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Characters per line:
specifies the number of
characters to print across the
pages. Characters per line
should be determined by the
horizontal printing area of your
paper and font size.

this frame you can specify whether
you want carriage control
information included with the
output and where you want page
breaks.

Lines on first page:
specifies the number of lines to
print on the first page.
Lines on following:
specifies the number of lines to
print on pages that follow the
first page.
The number of lines on the first
page and the pages that follow
should be based on the vertical
area of you paper and font size.
You may have to experiment with
this field.

Figure 4. Carriage Control
Information Frame

The generate" Carriage Control
Information field allows you to
specify whether you want to
include information about page
breaks. If you want to include
information about page breaks,
place your cursor on the YES field
and press ENTER. To remove
carriage control characters,
position the cursor on the NO
field and press ENTER. IF you
chose the NO option, the Signal
Page Skip parameters are ignored.

NOTE: The number of lines per page
and characters per line should be
exactly the same as specified in
the SAS options Pagesize and
Linesize. You can enter the value
-99 in the characters per line and
lines per page fields. This
indicates that the values for the
SAS options LINESIZE and PAGESIZE
should be used. Also, the number
of lines per page in the form
should be the same as the number
of lines per page the printer is
set up for (this could be set in
the printer control language panel
described below).

If carriage control characters are
being generated, you can specify
where you want page breaks and
other carriage control
information. Page skips can be
generated in any or all of the
following places:

First page/Following Page margin:
specify the top, bottom, and
left margins for the first page
and all additional pages. The
number of characters per line
determines the right margin. BY
default the top, bottom, and
left margins have been set to
zero. If a number other than
zero is specified, that numb~r
is added to the default margln
position of the printer.

Printer initialization:
before any printer control
characters are sent to the
printer to initialize the

printer.
First Text Page:
before the first page of text is
printed. This field must be
selected for any form that
contains printer control codes.

Carriage Control Information -To get to frame #3, the Carriage
Control Information frame(Figure
4), select 'Locals' -> 'Next
Screen' from the popup menu. In

Following Printer Control
Statements:
before any printer control
language is sent for following
pages of text.
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characters. These characters are
used both in the bottom portion of
the frame to define text
attributes and in the next frame
to define printing modes. You can
make changes to any of the fields
in this frame by positioning your
cursor on the field you want to
edit, then typing in the field.
You can receive information on the
acceptable values for any field in
this frame by typing a question
mark (?) in the field and pressing
ENTER.

Following Text Pages:
before the following text pages
are printed.
To select a field, position the
cursor on any of the fields and
press ENTER. An asterisk(*) should
appear to the left of the field.
To deselect a field place your
cursor on the field again and
press ENTER. The asterisk should
disappear.
Print File Parameters -- Select
'Locals' -> 'Next Screen' to get
the next frame, the Print
File Parameters frame (Figure 5).
This frame enables you to specify
print file information based on
the host system and printer
selected.
.

Printer control characters are
characters (typically nonprinting) that signal to the
printer that the text following
the control character is a printer
command. In these fields, you can
choose a printing character to use
in your form definition that SAS
will translate into the special
printer control character. By
default, SAS uses the tilde(-) to
represent the ESC keys and the
caret(A) to represent the CTL key.
If your printer uses other
characters as control characters,
they can be defined in this
section. For each control
character that you define, specify
the special character, its decimal
representation, and a description.

The Hold print request checkbox
can be used to hold a print
request. You can receive
information on the acceptable
values of any of the other fields
by typing a question mark(?) in
the field and pressing ENTER.

Figure 5. Print File Parameters
Frame
Font Contro1 Information -- You

can display the Font Control
Information frame(Figure 6) by
selecting 'Locals' -> 'Next
Screen'. The attributes defined in
this frame are based on the
printer you selected in the
Printer Selection window. There
are two parts to this frame. The
control character definition
fields(top part) has spaces for
you to define up to eight special
characters that are used to
represent printer control

Figure 6. Font Control Information
Frame

The low.er part of the font control
information frame allows you
to associate a color and/or
attribute(e.g., highlight,
underline) with a control code
used by your printer for printing
in special mode (e.g., italic,
bold). In figure 6, the color
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magenta is associated with the
text attribute underline. For
Example if you wanted to underline
a title, select 'View' -> 'Colors'
-> 'Title' from the popup menu of
the output window. Then click on
the button to the left of MAGENTA
and click on OKAY. When the
contents of the Output window is
printed, titles will be
underlined.

you need to specify. Your printer
manual should also describe the
order which the control codes
should be sent to the printer.
Your printer will not respond
correctly if all items are not
ordered correctly.

SAS supplies some default text
attribute definitions with the
correct start and stop sequences
for each special printing mode
supported by the printer that you
have selected. To specify
additional text attributes, enter
the color and/or attribute. The
Start field is the printer control
sequence required by you printer
to turn the printing mode on .. The
Stop field is the printer control
sequence required by your printer
to turn the printing mode off. The
Description field can be used to
document the printing mode you are
specifying.

Figure 7. Print Contro1 Language
Frame

To tell the printer when to use a
control language sequence the
following labels should be used.
Each Label should be placed a line
by itself before the sequence it
sends.

Print Contro1 Language -- Select
'Locals' -> 'Next Screen' to get
to the final frame, the Print
Control Language Frame(Figure 7).
Here you can enter control
sequences that are sent to the
printer. You can send control
language sequences before text is
sent, in between pages of text,
and after all text is sent. This
frame is especially useful for
formatting the contents of a
window without having to
manually adjust your printer
settings or SAS Setup and Font
options.

PRINT INn:
sends control language sequences
that follow before sending any
text to the print file.
PAGE n
sends control language sequences
that follow it to the print file
before the specified pages(n).
Where n is used to represent the
page number. The control
sequences will continue to be
sent before each following page
until another page label is
reached. The control sequences
can be stopped by specifying a
Page label with no control
sequences.

The Printer Control Language frame
is a text editor frame and all
text editor commands can be used
in it.

PAGE LAST
sends control language sequences
that follow it to the print file
after all text is sent for an
individual item.

The Printer Control language frame
can be used to set the page
orientation, the font type, the
font size, the number of
characters per line, or other
print characteristics. Your
printer manual describes the
control languages sequences that

PAGE TERM
sends control language sequences
that follow it to the print file
after all text is sent for all
items. This section is used to
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reset the printer back to its
default mode.
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